Update to BBC Symphony Orchestra v.1.2.1

Angus
Angus admin
500 Comments 50 Answers 250 Likes Spitfire Employee
edited May 18 in BBC Symphony Orchestra

An update is now available for Core and Pro users which patches the issue where the Transpose feature did not work in 1.2.0. Further updates to follow.

Please note that the role out to Discover user will take a longer period of time. You should expect the update within the next 2 weeks.

If you encounter any issues with the update, please reach out to our support team directly at spitfireaudio.com/support

A full change log can be found below:


Comments

  • Is this now M1 compatible? I notice your beta page hasn't been updated?

  • Awesome! Enormous thanks to Spitfire dev team for this fix! I really appreciate it!

  • Angus
    Angus admin
    500 Comments 50 Answers 250 Likes Spitfire Employee

    @Will BBC SO is not yet M1 Compatible, but we hope to put this into the next update due soon.

    Those seeing this post should also note the following:

    AAX AU Issue - there is an issue with the AAX in this build which Pro Tools does not validate. We have a fix for this, so just reach out to support at spitfireaudio.com/support

    Logic 10.5 compatibility - this version is not compatible with Logic 10.5 due to a bug in that version. We have reached out to Apple for further info on this. As far as we are currently aware, the workaround would be to update to Logic 10.6. This version is only available on Catalina 10.15.7 or above, so if you do need to update your OS, be careful of other software that might be affected (e.g. Waves plugins that require a paid-upgrade path to the new OS). Logic 10.6 is also only available with the latest version of Logic Remote, which is i0S 13.1. Check your iPad can run this version before updating. More to follow.

  • is there any method to rollback to 1.20? i hadn't read this note and now i can't open BBCSO discovery. I need to use mojave and i can't upgrade Logic at 10.6

  • Doc Bob
    edited October 8

    I just updated to v1.21. According to the version history 1.2 was supposed to add a cor anglaise to BBCSO Core.

    • “Core: Add substitues Legato (Extended) techniques to solo instruments: Bass Clarinet and Cor anglais” I can’t see one, is it supposed to be there?
  • That is odd. Core doesn't have either Bass Clarinet or Cor Anglais. My guess is that this was a typo, and should have said it was for Pro instead of Core.

  • @Angus I haven't updated yet. Will the Pro Tools fix be merged into the update from this point, or is it required to install it and then get the fix from support?

  • @Doc Bob and @Jonathan that refers to the new patches that were released with 1.2.0. BBC SO Core does not contain these instruments, however, if you download a BBC SO Pro Template from DAW Templates, your plugin will be Mode Switched to the translated patches (e.g. Cor Anglais in Core, is a pitched down Oboe).

    This is explained in greater detail in the video below:

    @Russell what Pro Tools fix are you referring to- failed AAX, or M1 compatibility?

  • @Angus This one. I run Windows 10.

    "AAX AU Issue - there is an issue with the AAX in this build which Pro Tools does not validate. We have a fix for this, so just reach out to support at spitfireaudio.com/support"

  • @Russell ah yes, this is fixed with 1.2.1, which is the current version. If not, reach out to support and we can send you a valid plugin.

  • Thank you @Angus

  • Doc Bob
    edited October 10

    Angus, thanks for that video and explanation. Is there a PRO template for Reaper? Or a workaround for Reaper. I have CORE but I can't mode switch up to Pro.

  • Doc Bob
    edited October 11

    Thanks again Angus. I opened the PRO template but the plugin is the CORE one, and I can't upscale to the PRO. The bass clarinet is present in the template but with no plugin on the track. Maybe I'm missing something but without the PRO plugin I don't have access to the missing instruments.

  • Hi Angus,


    I have a problem running BBC SO in Studio One. It always crashes the application. Please advice on this, thank you!

  • Hi @syabil51

    That will need further investigation. I've created a support ticket for you and someone will be in touch with you directly.