Error installing Helper

Hello,

I have an error message when I Try to open my Spitfire Audio application :

"Error installing Helper

Unable to install helper - Blocked by Launchd

Please enable in launchctl or contact support"

What should I Do?

I'm on Apple Big Sur 11.5.2

Thanks

Comments

  • I am getting the same error message. Any solution yet?

  • @Stephen202021 I’m not a Mac expert but do you have to “allow” it in Security Preferences?

  • @DjSladeProd and @Stephen202021


    I've created support tickets for both of you so we can have a look at this problem! One of our team members will be in touch shortly.

  • Does anyone have a solution yet? I have the same problem.

  • @el1502 have you updated to the latest Application?

  • yoas
    edited November 2021

    Im having the same issue. Unable to open the app. Kindly help resolve. I tried uninstalling the app from Mac M1 and reinstalled it without removing the vsts. But same results. How do i open a ticket to have it checked and resolved?

  • @yoas I have created a support ticket for you so a member of our team can assist you directly.

  • Anything new with it?

    I still can't install it :/

  • @spaviram I'll create a ticket for you. We'll need to resolve this with steps we can send via email.

  • I have the same problem! Could anyone please help me with that?

  • Yes @Justin0603 I've created a ticket for you.

  • I have the same problem! macOS Monterey 12.01

  • vadim
    edited December 2021

    So I dug some information about launcd and launchctl and managed to solve this issue: my problem was that I had manually switched off the auto update for Spitfire in my Mac cleaning app. I've just switched it back - it helped

  • Please help me. I also faced this problem. MacOS Monterey 12.0.1

  • @minor_dm I have created a ticket for you. One of our agents will be in touch.

  • i've got the same problem. i used a cleaning app as well and i think that might have removed something. annoying!

  • oh, someone helped me on an apple forum... they sent me this:


    "Jack mod


    October 29 edited November 2

    Hi everyone,

    If the above solution don't fix this issue you can try the following:

    Open terminal, copy and paste the below command and hit enter. Run the app. 

    sudo launchctl enable system/com.spitfireaudio.LibraryManagerHelper
    

    If it fails, get in touch with us via a support case and we will look over the permissions relating to this problem which will likely require remote access.

    Thanks

    Jack