Does anyone else use a midi drumset to play LABS?

I had posted recently about an issue I was having trying to use my 2 midi drum controllers (KAT drum pad and Alesis Nitro drum set) specifically with LABS Drums, but I was wondering if anyone else has tried to use their midi drum sets with any LABS plugins. If so, are you experiencing any issues and/or how did you work around it?

Answers

  • If you're trying the Drums library with the current version of LABS, you will have some troubles anyway. Some drums will cut off others, like kicks will be cut off by hihats or cymbals. It's not a problem with your input devices.

    Try to give Percussion a go until the next version of the plugin comes out! Should work fine. But, I know, it doesn't have the same punch, grittiness and flow that somehow has been in the Drums. Can't wait for those to work again properly! πŸ˜ƒ

  • Hey Taron, thanks for the reply. Have you tried Percussion with a midi drum set? I actually tried it as a last resort and could barely get any sound (using both my midi drums). The admins actually had be download the 1.4 version of LABS to try to fix my issue with LABS Drums (snare and bass barely responsive to midi drums while all other sounds worked fine), but after trying it with both my midi drum sets and both of my laptops the issues continued. I just wanted to see if anyone has had any success using midi drums to trigger any of the LABS plugins.

  • @Taron that should be fixed with Plugin version 1.4.0- which is now release and available by repairing or downloading any LABS library

  • HURRAY! 🀩 😍

    I will do so right away! Thank you, Angus, and the whole team! πŸ€—

  • Taron
    edited August 2021

    Alright, so I've "repaired" it and it sure almost works again! This kick still cuts itself off with velocity changes. Like hit it hard and then softly right after and it will cut off the loud kick badly. I'm almost sure it hadn't been that way originally. But overall: FANTASTICO! πŸ‘οΈ

    @stiltzwaffles As for midi drum devices, well, I'm assuming there may be an issue with your velocity sensitivity. The drums appear to have some sort of a steep curve, which may be almost inverse to your midi triggers' velocity curve. I can only guess. You could try and have a look at your recorded midi pattern, check the velocities of it. It might really just be a quirky difference in philosophy that can be remedied easily by some minor adjustments to your device. One could argue, this would make such adjustment options desirable on the LABS plugin... I'm sure it would be super-thoughtful and generous. πŸ˜‰

  • @Taron I'll check this out and report it to our team- thanks.