Spitfire Player settings? (Disk/CPU)

I've noticed even running something like 4 mics simultanously(spread out between different instruments or all on the same one) causes disk usage to spike, causing a CPU spike and droppouts.


I'm using reaper with a fairly reasonable buffer(384 iirc) but I don't know why I can't get smoother performance/more polyphony out of the spitfire player.

I'm streaming from your standard 850/860 evo's SSD

I've got plenty of ram to spare, and quite a strong CPU... anyone have any tips? (I'm using reaper)

Comments

  • Angus
    Angus admin
    500 Comments 50 Answers 250 Likes Spitfire Employee

    Using more Mic signals means that there will be more CPU load, as more audio files are pushed through (each mic signal doubles the amount of original samples). If you find you are getting CPU dropouts, I would recommend the following:

    • Try upping your Sample Buffer Rate to 1024 Samples if you have not done so already. Although this isn't an ideal buffer for playing in parts, it will mean your system has more room to breath.
    • Freeze, or bounce in place, any tracks that aren't in use. This will reduce the CPU and RAM load on your device.
    • Check your SSD is formatted correctly for your OS (Windows= NTFS, Mac OS 10.10-10.13 = Mac OS Extended (Journaled), Mac OS 10.14+ = APFS)
  • Thanks for trying to help, but I fear you misunderstand the level of performance of my machine vs what the spitfire player is achieving.

    "more mics" isn't the issue - even so much as trying to play 4 legato patches(i.e. woodwinds) simultaneously causes dropouts. I have PLENTY of ram.

    My SSDs have been formatted correctly, I've been using these drives for all sorts of sample libraries on multiple sample players - but the spitfire player doesn't seem to be able to read from the disk fast enough. I assume it's intended to be able to handle orchestral writing. That's why I was wondering if there were any particular voice + preload size people use.

    So far I'm going to try doubling everything.

  • Reaper can override your soundcard's buffer settings. Maybe check that. (or uncheck :)

    e

  • Nah, I use the same for both.

    Been using reaper for about 9 years now.

    For some reason the disk reading is just really slower than make sense... I doubled/tripled/quadrupled some of the buffers and just about doubled the ram requirement and it's running a little better but seems incredibly inefficient - so I thought I'd try the sample memory function but it just crashes me.

    Does anyone else here use bbc professional on reaper? Before the last update I used to get crashes often so I just set the library aside but maybe it's just not performing well in reaper?

  • Angus
    Angus admin
    500 Comments 50 Answers 250 Likes Spitfire Employee
    edited March 24

    @ProfoundSilence it's important to note that having a high amount of RAM does not necessarily mean you can stream a high amount of audio. If using many mic instances, or more than 50 instances of the plugin, you should look into upgrading your CPU. This is because, the more audio loaded into RAM and streaming into your system, the more processing power is required to handle said audio.


    Of course, you should first look into other options, as you mention regarding playing around with the plugin audio settings. But you should also, play around with your DAW preferences that pertain to CPU (e.g. Threads, Sample Buffer Rate, ASIO Guard if applicable).

    Also check this article out regarding enhancing performance on Windows if you are indeed using Windows:



  • 16 thread i7 needs upgraded for 4 simultaneous legatos?

    It's clearly a technical issue, just wondered if anyone else encountered it. I'll take my time and just ask the support team when I'm ready.

  • is this the way to work in 2021 with a modern sample player..?!? SA put 100's of mics in the plugin that nobody can use - what a joke. other player like SINE from OT have nor problmes at all and are as well multitimbral. and this is a shame because BBS So and AR1 sounds really good - but i can not work with it because of the CPU Spikes.

  • @Markus i know tech issues can be fustrating but it is unkind and also untrue to affirm that “ nobody “ can use Sa. I notice other posters have attempted to help you with what appears to me to be a sensible check list of good suggestions which could solve your issue. Why don’t you read the posts and act on the advice.

  • Angus
    Angus admin
    500 Comments 50 Answers 250 Likes Spitfire Employee

    Hi @Markus

    Sorry you feel that way about the plugin. If you do get CPU spikes, you are more than welcome to contact the Customer Experience team at spitfireaudio.com/support

    We can then access your system, template, and workflow, and make any recommendations that may help- as well as providing any feedback to our engineering team should more optimisations to the plugin be required.

    What I will add, particularly in the case of Abbey Road One, is the microphone signals are not designed to be used all at once. They are also for use at the 'mix stage', where you have finished your composition, and can now experiment with different mic mixes- running a high buffer rate.

    I'd recommend you watch Paul's video here, which includes advice from Simon Rhodes (Abbey Road Producer) on what are the best combos to use:


  • Let's not derail the fact that I started this because simultaneous instruments being played is causing the same issue.

    Hence I was wondering what people use for settings.


    Huge buffers is not an option

  • Angus
    Angus admin
    500 Comments 50 Answers 250 Likes Spitfire Employee

    Hi @ProfoundSilence

    You should always consider using a high buffer when you are at the mix stage. The advantage to a low buffer is the lack of perceived latency between the keyboard note and the sound being produced by your computer, however, this shouldn't be a factor when you are at the mix stage and ready to experiment with additional microphone signals- if you have completed the compositional element.

    Having a high buffer puts less strain on your CPU, and will prevent any audio glitches occurring within your DAW that can (in rare cases) damage audio equipment.

  • I'm talking about writing, and having an orchestral package that can't play 4 instruments simultaneously without crackling using default settings doesn't seem correct.

    In comparison using sine and Kontakt I'm able to play live 24 legato patches at once.

  • Angus
    Angus admin
    500 Comments 50 Answers 250 Likes Spitfire Employee
    edited April 7

    @ProfoundSilence if you do find you are having continual issues, even with a high buffer rate, and having optimised the library for your system, do get in touch with our Support Team. We can assess your system and suggest any further hardware/ software optimisations that might be made, or officially report any issues to our engineering team to look at for a future update.


  • Well I won't bother with a high buffer rate, if I can't use it like any of the other sampler/romplers I'll just let it collect more dust until the engine sees performance improvements.

  • Adam Roberts
    edited April 9

    Dude...reach out to support. They're really good at it...fixed everything I've encountered so far.

    Or don't. Whatever...

  • seems to me that slow I/O is caused by bad programming, the only hope is that they will fix it /rewrite code in the future... or not :(

    player looks like project in alpha stage, nice design, nice user inteface (minus pointless knob thing) but code far from being optimized.

    i guess we have to wait.

  • I was in contact with support for several months - but there was no solution to my problems. The supporter was on my machine and saw all my PC Spec. etc. and he saw also the difference between other player's that i use. I can post here me PC Spec's and Latancy Monitor Stuff - but for what. The Player is an issue - and i am not the only one. And to record with 1024 only when i use AR1 is also not a solution at all. When i can record all other stuff in Kontakt or Sine in 256. i split already out single tracks for every mic.

    @Des be sure.. i read all the posts - but nothing of that is a solution for this problem. i send some screenshots from the CPU use. The Player ist not able to suport a Multicore PC System - end of magic

  • Unfortunataly I also experience these problems.

    I tried everything that support suggested, no solution.

    PC, Win 10, Cubase 10.5 pro, i7-8700K, 32GB RAM, Dedicated 860EVO SSD for the Spifire plugin, windows defender is switched off on this drive.

    Longs and legato patches of BBCSO or AR1 overload the cpu very quickly...

    I think the problem may be related to release and legato samples.

    I can confirm that there is no such problem when using KontaKt or SINE libraries.

  • There's a way around this problem but it takes longer but eases your computers CPU usage Disk etc, obviously you can't add lots of instruments in Albion 1 in Kontakt for example because it'll glitch out and stop.

    Play 1 instrument and as soon as your happy with it, render your midi notes into audio, disable the kontakt player and use the sound from the audio, this will help when you come to exporting your project, it takes a while but if your winging it like me with old technology, this is the best advice I can give.

    I use cubase, you can stretch the audio file with the warp function to hit the markers you have set perfectly, don't stretch it too far though as it'll make it sound slooooow :) I hope this is of any help to anybody.

    I'm going to be looking for a new pc next year :)