What is the maximum number of instances of BBC Core in one template?

I'm using Hexachord Orb Composer Pro S V 1.5 ( an AI driven composer tool) to play with some musical ideas.

To make it work, you need to assign for each instrument and articulation a VST. For the "Orchestral" template you have to assign a couple of hundred links like that. Basically you are making a template.

I use BBC Core as my orchestral base VST. When I reached 200 assignments of that VST, the audio went crazy: a lot of interruptions, stuttering and fall outs. No matter what value I used (64 till 1024) for the buffer size, nothing helped.

My soundcard is a Focusrite Scarlett 18i8.

Specs of my PC:

CPU = AMD 7 1700X eight-core processor 3.40 GHz

RAM = 32 GB

SSD 250 GB

HD 1TB

SSB 1TB (on which my VST's are stored)

I've never made a template before, so I was wondering: is there a limit in the number of instances you can assign with the same plugin?

Who can help me out?

Comments

  • I've never used Hexachord Orb Composer, so I can't speak to that, but in other software the number of instances you can have enabled simultaneously is largely dependent on RAM. Does your system still have RAM available or is it close to maxing out? Is there a way in your software to disable instances/articulations that you're not using?

  • The max instances is determined by your ram, not the actual plugin. The plugin tracks how much ram is using, and you can use like task manager to watch how much ram your PC is dedicating to your daw.

  • Angus
    Angus admin
    50 Answers 250 Likes 100 Comments Spitfire Employee
    edited August 11

    @Dirk_C I recommend opening Task Manager to see what is peaking. Typically, this will either be caused by your RAM maxing out (as @gregoryd suggest) or your CPU overloading, due to the sheer amount of audio being processed. For CPU overloads, you should consider running a higher Sample Buffer Rate.

    Another aspect to watch out for is your Disk- where you have stored the library. We recommend SSD's with a transfer speed of more than 500mb/s in order to run smooth sessions. You should also make sure your SSD is formatted to NTFS for PC.

    To answer the original question, there is no limit imposed by the plugin on track numbers. But there will be a track limit in your DAW, and limitations depending on your PC Specs.

  • In BBC Core there are ways to disable articulations, so I can give that a try. Thanks for your answer!

    Dirk

  • I'll check via the monitoring tab in the task manager how the RAM is behaving. And with 32 GB RAM I'm supposed to have some room for a lot of instances (I think).

    Thanks for your answer!

    Dirk

  • I'll check with the task manager and if the RAM is full, I have to put some more in my PC. For the moment I have 32 Gb RAM, which is a reasonable amount.

    I 'v tried already a higher sample rate, but that was not a solution.

    And my VST libraries are stored on a SSD-drive, so that is not the cause of my audio problem, I think.

    Anyway, thanks for that quick reaction!

    Dirk

  • Hi @Dirk_C


    You may also find this article helpful. If your CPU is overloading (which it sounds like it is), but you have additional RAM storage available, you could increase your Preload Buffer Size in the plugin to put more samples into RAM and hopefully reduce CPU strain.