Updated Reaper template for BBCSO Core, Pro now available + important bug fixes

HewWagner
edited September 2021 in DAW Templates

Hi everyone!

I've updated the Reaper Template for BBCSO Core and also now made a Pro version, though that will require a bit of set up on your behalf.

There is one very important bug fix: All tracks that record output are now set not to compensate for latency, which isn't the right setting for this application (It's more for recording something in live instead of bouncing a mix).

The new versions are attached, please let me know if you have any questions, ideas or feedback, or find any mistakes I've made setting it up.

The download is here:

Happy composing,

Hew

----

Update notes:

-

What's new:

All instruments are updated to the 1.2 version of BBCSO.

Muted Brass articulations have been added.

There are now group tracks for Reverb 1 and Reverb 2 to help you easily control the overall level of reverb. Advanced users might consider changing these from groups to VCA tracks. Note that the sends on the reverb tracks for Stems 6-9 are muted by default, you can change this easily in the mixer.  

Percussion is now grouped into three sections: Drums, Metals and Miscelaneous, and Tuned. 

-

Fixes:

All tracks that record output are now set just to "record output", not "record output latency compensated". Apologies for anyone this caused trouble for!

Placeholder fx for Stem 9 are now on the correct track. 

FX Tracks are now all muted by default (I'm not sure if this was a bug in the original version or something that I let in later).

Sync Plop channels are now set to -8db by default to save your ears. 

Comments

  • I meant to also add:

    If you've made lots of modifications to your template from the original version and don't want to start again from this new version, be sure to do these two things:

    1. Right click the refresh button at the top of each instance of the BBCSO plugin and click "Update instruments to latest version"

    2. Set all print and fx tracks to "record output (multichannel)" instead of "record output (Mulitchannel, latency compensated)" so you don't have timing issues when bouncing to stem and fx tracks.

  • @Glynn Hew has included a Pro template in this build!

  • Thank you for the update to this template @HewWagner

    I notice on the main template site that it is still just Core version up, and nothing on the Pro area. I wonder if someone at Sptitfire audio can update spitfireaudiothepage.com with the new Core and Pro Reaper Templates?

  • Thanks a lot man!

  • @MarkSpooner we've stopped updating The Page to focus on other projects. All new templates will now be uploading to the forum (Tech Talk - Templates). Hew's template above contains both Core and Pro templates.

  • I upgraded to BBCSO Core 1.5 from Discover, and was delighted to find this template. When I load it, though, even with all the BBCSO plugins offline Reaper starts consuming 50-90% CPU and even a single enabled track produces garbled audio.

    I'm using a Windows 10 laptop with an i5, 8GB and an NI Komplete Audio 6 USB interface. A Discover 1.2 template I created myself worked fine even with all the plugins online.

    I'm presuming it's not like that for y'all, and with CPU utilization numbers that far out of bounds that it's not just that I'm underpowered.

    Any thoughts or advice?

  • Looking at Hew Wagner's Reaper Template v1.2 for BBC Core, and have some beginner questions.

    I guess I don't understand why Hew adds the effects to the FX Channels (down below the stems) instead of to the MIDI instrument track. Secondly, is there a way (without opening the mixer window or having visible every kind of channel) to see what effects have been applied to a track (assuming the FX was added to the FX track, instead of the Instrument track). Hew added a shortcut "F - Toggle Show FX Chain Windows for Selected Tracks" in his video (at about 9:27), but that only brings up the instrument window, which only lists VST3i BBC Symphony Orchestra - so I'm not seeing what benefit that gives you. The attached FXs like reverb, EQ, he has attached way down the chain, to the FX Channel aren't indicated.

    Is there an easy way (SWS shortcut?) that allows me to see this info from just the instrument track?

  • @billkelm

    Hey, sorry for the slow response. So the main reason for the way it's set up is that I was copying the layout that Jake Jackson and Christian Henson created for the BBCSO template, if you watch all the videos they made at the time about the template there's lots of great nuggets of information as to why things are laid out the way they are, along with many other tips and tricks.

    For reverbs, having them set up with the effects tracks means that you only need one set per instrument group, like you don't need a plugin for every individual instrument which would get very resource heavy and unwieldy if you want to change settings. For other effects (such as delays), they're set up like this so you can put multiple tracks through the same effect, or so you can set-up out-board effects to go on one of those tracks. This setup also means that you can easily export with or without these effects, a mix engineer may want to use their own reverbs and delays - my understanding is that this is important if working at a pro level for film or tv.

    Personally I use the reverbs as they're set up with the FX tracks (well, with my own plugins on those stems), but almost never use the FX tracks for delays or other effects. If I want a delay or whatever on an individual instrument, I'll just put it on that instrument's track.

    Yeah I don't know of an easy way to see the info of all the effects that are on in instrument down the line, just from the initial instrument's track. Generally I hide the mixer (Ctrl+M) most of the time and only open it when I want to look at those fx tracks.

    You can open the routing window to see where it goes and follow that chain from there (sadly if you click that it doesn't like go straight to that track like it perhaps could!) or check out the Routing Matrix (Alt+R) but it does all get a bit unwieldy caus of the sheer amount of tracks. I haven't tried it out yet, but there's a recently released add-on for Reaper called LKC Content Navigator which I'm going to have a try of once my current projects finish up: https://twitter.com/lkctools/status/1482838619975045123

    I hope that helps!

  • Hi Hew, I've been away, but am back and picking BBCSO up again (wrt high CPU consumption).

    First, wrt your suggestion about loading the template project in recovery mode, that didn't reduce Reaper CPU consumption. Still 50-90%, and even a single activated plugin produces garble.

    Reaper Performance Meter doesn't single out any particular track as the cause. With nothing activated all show 0.00 or 0.01 (yet total CPU shows high here, and in Windows Performance Monitor).

    Deleting the click tracks did make a minor reduction. Continuing to slash and burn from there, deleting the stem and print tracks (taking me down to 168 tracks) did get my CPU (with one plugin enabled) down to 15-30%, and allowed that track to generate clear audio.

    I've been reading some Reaper blog threads on folks having CPU problems with large numbers of tracks, so clearly there's some price for a track even existing. But these folks are talking thousands of tracks, not a few hundred like your template uses.

    So, it remains a mystery to me for now. If you and others are having success with the template on current Reaper release on Windows PCs in the i7/16GB range, then I can only assume there's something inherent in my particular setup. I'll keep digging into the Reaper forums and see if anything turns up there.

    Thanks for your earlier reply,

  • Yeah that's at total mystery to me as well - what a hassle :(

    The only thing I can think of is checking your audio interface settings and buffer output. I doubt that has anything to do with it though, unless things are accidently set to some windows audio thing rather than your audio interface (I use the Komplete Audio 6 as well, make sure your buffer settings aren't at the 1024 or 2048, I get some pretty weird things happening if I set it to those). You could try ASIO4ALL or the FL Studio ASIO driver to rule that problem out?

    Or try a fresh install of Reaper maybe? Perhaps there's a setting somewhere that's been chosen incorrectly by accident, Reaper has some pretty esoteric options.