kepler orch high on cpu

hi to all,

I wanted to know if anybody else got this problem - the Kepler orch vst is very high on cpu usage pops and clicks especially when I'm changing chord or note (on keyboard). does someone know what to do?

I'm using a pc, 128 ram, win10, all ssd hd, rme ufx ii, cubase 11 last update, kontakt 6 last update.

should I change something on Kontakt? (using only 4 core multiprocessing, and didn't change anything else on memory label)

thank you

Comments

  • Jack
    Jack mod
    5 Answers 25 Likes 10 Comments Spitfire Employee
    edited March 19

    Kepler is known to be pretty Cpu heavy because it is constantly stretching its samples to match the BPM of your DAW. The samples have to be programmed in time machine groups which make this feature possible. As a result of using these groups Kepler becomes CPU heavy.

    There are a number of ways to try and smooth Kepler:

    1) split chords out across individual tracks. This spreads the TM group load out across cores of your machine. Ensure that these individual tracks are being placed in folders. Instrument tracks in most DAWs thread audio / instrument processing to a core of your machine, so this spreads things out. A folder would group the workload back together on one core.

    2) run the DAW at higher buffer rates on playback and freeze tracks you are content with.

    3) use less microphones, this means you are triggering less TM groups in the patch.

    These are just a few things you can dive into, but if you have further questions, we'd be happy to help on support with optimising further.

    J

  • Jack has some good suggestions, but there is a few other things you can do.

    1. Use the "mix" patches, which offer a pre-made stereo mix of the various mics. You'll get the sound of multiple mics, but only have one mic signal to process. If you want to use a different mix when freezing / bouncing / exporting, then just open a second (regular) patch with the same settings, and your desired mic mix. Keep the "mix" patch solo'd when writing, and then solo the regular patch when freezing or bouncing.
    2. Turn off the "Quantize in" option, and quantize your MIDI directly if needed. This is a handy option to keep everything synced up well even if your MIDI is a bit sloppy, but it is quite heavy on CPU.
    3. Turn off the FX peg for any used column if you don't need it. The effects are pretty lean on CPU, but every little bit helps here.