Why is LABS so unstable?

edited May 2021 in LABS


Love the LABS series, a lot of great sounds I love to spice my compositions with. But I'm constantly having problems with Spitfire Audio App and LABS app in Logic only finding a few of my installed Libraries, which is frustrating! Now it happened again. Using an external SSD, formated as OS Journal, AND have reinstalled all the LABS-libraries in the Spitfire Audio App. But when I open LABS in Logic, it only finds like 5 of the 30 libraries! Why? Any tips?



  • Never have any issues myself.

  • Never had that issue either.

    Are you installing all the libraries to the same folder? Can't see why or how it'd only find 5 of 30 libraries if they're all in the same directory.

    The LABS app is just a VST plugin, like any other.

    Good luck!

  • Yes, I've had the same - even after I spent hours getting things that had de-authorized to show up, half of my now-perfectly-functioning LABS show "not installed" in the app. It's a headscratcher, but hey, they're working, so.

  • Same issue here. I have all my libraries on an external drive, but when I switch between computers I've come to expect at least some of my Spitfire libraries to be broken. It's tedious and frustrating, because in some cases it requires a total reset and re-download. I love Spitfire Audio, but their software could use some work. I don't have this problem with any library from other companies.

  • Yes, they are installed in the same folder. Deleted them from the internal harddrive, and re-installed them on an external SSD-drive. I don't know either, It's a real head scratcher! And it's like bingo everytime I open the Spitfire Audio App if a library is marked as installed or not. No clue why. This doesn't happen to mye paid and bought libraries, they seem to be stable and work fine.

  • gregoryd
    edited March 2021

    So when you install Labs, you are instructing both Logic and the Spitfire Audio App a very specific location of your installation. The pathing from one PC to the next is not always the same.

    From what I can tell, you need to do a full uninstall/deleting of every instrument and find a permanent home on your PC with the Labs plugin. They don't function the same way as the other paid libraries. This is probably because the coding lists the specific drive port that your removable storage is plugged into. When you have a bunch of USB drives plugged in, your computer assigns a letter in front of it to organize them.

    This letter is probably not the same from one PC to the other and is probably why it isn't finding your library. I'm not sure about this; I don't know a lot about coding. It seems to resemble how in Kontakt it can't always find a specific file except Labs doesn't have a way for your to update where it is.

    I'd highly consider just finding a permanent home for your Labs. You are right; they don't work too well on removable drives. If you leave it plugged in and don't switch PCs they should function properly without problem.

  • Kerry
    edited March 2021

    That’s definitely good general advice; on my own Mac (which I’ve owned for far too many years) my LABS folder remains on the internal SSD, which I run disk utilities on fairly regularly, so I’ve ruled that out already.

    I hesitate to do anymore resetting of anything than I’ve already done - I ran afoul of the arbitrary limit once before trying to get everything working and had to send in a support ticket - and the words “not installed” don’t bother me as long as the instrument itself shows up for work. It’s great sounding stuff for free, so I’m quite satisfied. The only harm is an occasional twinge from my OCD when I open the Spitfire app :-)

    I just thought I’d chime in to say “yes, I’ve noticed there’s something not quite right about the way it’s keeping track of things” in case it helped anyone narrow down their troubleshooting.

  • Kerry Smith
    edited March 2021

    I find that, even having everything saved to the same drive and not moving things within my template, SF-player products (except BBCSO for some reason) are as apt to not find the samples and throw a "Something's Wrong" message, as not. Using Pro Tools on Mac with the Libs on a dedicated SSD, FWIW.

  • Kerry
    edited March 2021

    Just to put things in context: I have full commercial versions of Izotope Post and Music bundles, which are not inexpensive commercial packages, and they will suddenly decide to deauthorize themselves if you look at them sideways.

    Most recently it was an OS upgrade that did it - I started the back-and-forth with Tech Support a couple of weeks ago and they’ve been out of service since then.

    And just this morning I received an email from Izotope saying they’ve upped my authorization limit - which is kind of them, but has to be viewed in light of the fact that I’ve never authorized them anywhere else, and my authorizations were spent dealing with it randomly deauthorizing itself at awkward times under deadlines. I have to consider that package “unreliable” now since it’s subject to going away for weeks on time at a whim (I had a mix deadline in that period and deadlines don’t care “why all your compressors died”, you just have to move on to other tools). So all in all I consider dealing with the LABS authorization issues to be pretty minor.

  • Hi @Nikolai

    There certainly should not be any instances where LABS would exhibit an error on its own accord without a change in your system settings. Common user errors (that may not apply but are worth knowing about) include:

    • Removing an external storage device where the library folder is stored
    • Installing a new LABS library to a different location (they all need to be contained within the same folder)
    • Repairing a LABS library in a different location (this will just replace the patches and presets for the library, and you will be missing samples a.k.a Error 4)
    • Installing the library from an Admin account, and then attempting to use it on a User account (Error 5)
    • Moving the library folder without telling the Spitfire App (need to use Locate within the App)

    In your case, it might be a more rare issue we occasionally get. I would always recommend writing into the team so we can help you fix this, and also improve the plugin, if necessary, for other users. Please feel free to create a ticket or start a chat at spitfireaudio.com/support

  • Hey Angus, thanks for the response. These are interesting, I will check to see if I ever ran foul of these:

    • Installing a new LABS library to a different location (they all need to be contained within the same folder)
    • Repairing a LABS library in a different location (this will just replace the patches and presets for the library, and you will be missing samples a.k.a Error 4)

  • Thank you for the tips :-)

    Ah! I think I found the problem! The latest libraries have been installed on a newer SSD (I have 3 SSD's for sample libraries) as I picked this new SSD as a standard installation site for new libraries within the Spitfire Audio App when the first external SSD was full. Just repaired the libraries and installed them all in the same folder, and that seems to have solved the problem!


  • This missing libraries problem just happened to me! I have all LABS installed, but only three of them showing. Everything is in a single location under Spitfire in my home directory - which I believe is the default. When I look in, only the ones having some size are working:

    But I definitely didn't go in and delete something manually.

    I noticed that sometimes I have to repair something here and there before, but this is massive and I have to Repair it one by one now?

    BTW: After clicking Repair the second time, there should be some busy cursor as there is no indication that something is happening and the UI just goes unresponsive.

  • Hi @virgo47

    This looks like it may need some further investigation from our team. I've created a support ticket for you and we'll be in touch shortly.

  • I am also experiencing these issues os instability. One second all my libraries will disappear. I'll get the error notification. Run through the protocols of repairs. Only to have nothing change.

  • vandeen
    edited August 2021

    I run Spitfire under WINE in Linux, & every time they update the Spitfire Audio Program (it won't let me run it without upgrading it so no option to opt out) everything on LABS breaks & has to be completely re-installed. 😥

    Recently upgraded to version 3.3.10 & currently having to download & fresh install 200gb+ of labs instruments once again.

    I tried to run the both the bulk repair function overnight & also this morning but it doesn't complete & crashes.

    Then I tried repairing each instrument individually this morning, it appeared to work but hasn't fixed anything.

    A clean install every time is the only thing that works :-( (& at 10 - 15 Mbps it takes some time 🤦‍♀️)

    I appreciate that Spitfire openly state that they don't support Linux, but I'm extremely happy with my BBC S.O. pack, & it always works flawlessly, every time, even after the updates.

    I really wish the LABS stuff shared the same stability, as there's some great sounds in there that I love to use. 👍️

  • @imjo would you be able to provide more detail here?

    • What error do you see?
    • What OS are you running?
    • Is the library located internally or on an external drive?
    • Are you using multiple accounts (Admin and Users) on your device?

    @vandeen we are not compatible with Wine or Linux, hence why you are having difficulty here. Our products are currently only compatible with Windows 7 - Windows 10, and Mac OSX 10.10 - Mac OS 11.

  • @Angus :- we are not compatible with Wine or Linux, hence why you are having difficulty here

    Yes I know, hence me saying " I appreciate that Spitfire openly state that they don't support Linux, but I'm extremely happy with my BBC S.O. pack, & it always works flawlessly, every time, even after the updates."

    Labs is working fine again now after I've re-installed the instruments, it's just a bit of a hassle, shame there is no option to ignore or postpone updates.

    Is it not strange that the BBC S.O. always works fine for me though? & it's just the LABS stuff that gets affected?

  • Angus
    Angus admin
    100 Answers 500 Likes 500 Comments First Anniversary
    edited August 2021

    @vandeen when you say Update, do you mean the Application updating or LABS updating? We recently included some improvements to the Application which stops an unfixable Error 1 issue a small amount of Windows users were having difficulty with.

  • Hi Angus & others,

    I'm so glad to see that Spitfire is looking into these issues, especially considering this is a free package. I also have the same problem of LABS randomly "forgetting about" instruments, & I often find myself needing to reinstall literally everything when I want to use the plugin. I figured I'd drop some details in hope that it's some help.

    Surface Laptop gen1, i5, 8gb RAM, Windows 10 Pro x64

    I install applications to the system directory, but keep most data on a large external drive, assigned letter Q. All applications requesting a "data" or "content" or "data" path are directed to this drive, including my DAW, photo editor, video editor, &c. My Documents folder is set to "Q:\Documents"; I have LABS set up to store its content in "Q:\Spitfire Audio".

    I don't know if it's the external drive setup that drives LABS mad, as the others have speculated, but if it is, LABS is the only app I know of that doesn't play nice with this configuration. The photo editor that came with my camera goes so far as to crash if the external drive is unplugged, but it's not a permanent state, and all I have to do is restart the application with the drive connected to continue. My DAW will throw an error about being unable to load its built-in FX, but it never permanently forgets about them, and starts up just fine next time.

    I was very diligent about having the drive attached every time I started LABS, but it seems to have been no help. I started LABS a few hours ago to find it had "forgotten" everything again, except the Moon Guitar...which it threw an Error 1 at anyway.

    Another interesting behavior is that the application is unable to reinstall these instruments from its content path. Despite the data being untouched and presumably intact, an "HDD Install" nonetheless redownloads everything. I'm still waiting on the app to redownload literally everything so I can get back to work.

    I can confirm that all of my physical kit, operating system, &c, is fully functional.

    I am so appreciative of Spitfire for providing this amazing library, which has quickly become my go-to tool. If these app kinks can be ironed out, I will no doubt consider purchasing some libraries in the future—but right now I don't trust it not to be a headache!

    I hope this information is helpful. Best regards to you & the rest of the team.


  • Hi @absolute_none

    Thanks for detailing your info there.

    I realise this is most likely not the case with you, but I will mention anyway that the plugin currently cannot share an install location between two devices. i.e. if you move the hard drive to a second device and relocate the library in the App, it will break the install (Error 3) on the original device. This can be fixed easily by locating a single LABS library, which will relocate them all: instructions on how to use Locate here.

    Secondly, we recently update the App with optimisations on Windows that prevent Error 1 from occurring randomly. You should make sure you have the latest App installed (available on the website, version 3.3.10) and the latest LABS plugin installed (v.1.3.11). This can be installed by repairing all LABS. Before you repair, make sure the Default Content Path in the Application settings is set to your Q drive.

    After that point, if you still have an error, this might be because the drive is unnamed. However, the plugin should still recognise the installation, so it would be good to follow up on this if that is not the case.

  • vandeen
    edited August 2021

    Hi @Angus

    The problems arose after having to update the Application to 3.3.10 & having to re-install all my LABS instruments.

    The latest LABS version I have found that works under WINE in Ubuntu Studio is 1.3.11 & this works for both 32 & 64 bit, in both .dll & .vst3 format

    Since Spitfire have updated the Application to 3.3.10 & I've re-installed the instruments unfortunately this now only works "of sorts".

    1) I don't have the nice interface to select instruments just the left and right arrows at the top of the LABS window to scroll though them. Clicking the dropdown arrow now closes the pluggin & switches it off in the CARLA rack in the DAW.

    2) I had to reload every instance of the pluggin back into a previous backup project which contained the raw midi files as it crashes Reaper on loading with the pluggin already installed on the tracks. (Also I couldn't save any new version of the track with them installed that would load back in without crashing the whole DAW) Fortunately I rendered the stems out as .WAV's before closing.

    Version 1.3.5 of LABS unfortunately gives the famous ERROR #1 and despite following the standard Windows repair procedure this doesn't fix anything.

    As previously the BBC SO pluggin has remained consistently stable & worked brilliantly throughout, & has even been adopted by others in the Linux & Reddit music communities following my recommendations.

    EDIT: PS Just noticed the dropdown instrument selector no longer works on BBC SO v1.1.9 GUI either, but I tend to use the graphical orchestral click & select so hadn't noticed that before testing it today. I'm running Ubuntu Studio 20.04.2 LTS and wine-6.5 just in case that helps anyone else looking to use BBC SO.

    EDIT 2: Any track I try and create & save which has BBC SO installed on it now crashes my DAW on loading the project in also. Again this didn't happen before the update of the application to 3.3.10 & the subsequent re-installing of instruments.

  • Hi @vandeen

    LABS 1.3.5 was released last year, and the current version is 1.3.11. If you have recently installed a library, or successfully repaired, the Application would have overwritten this plugin. This points to the issue being that VST location you have set in the Spitfire App Settings tab does not match the location where the LABS library is installed.

    As mentioned, we do not support WINE or Linux, which means I unfortunately cannot assist you on troubleshooting your devices, as the plugin and App infrastructure were not built for these OS's.

  • I'm having the same issue, installed all labs, today I had 4 of them saved, the others just vanished.

  • @Minz I've created a support ticket for you. One of our agents will be in touch.

  • Today's resolution notes from 'LABS instruments missing' 

    1. Applied Spitfire Audio software update.

    2. Found many (not all) LABS instruments missing.

    3. Reviewed DAW documentation, checked for, and then resolved end-user errors.

    4. Worked with Spitfire Audio onboard troubleshooting tools (located samples, repaired samples).

    • Encountered 'Error 4' in the DAW.

    5. Logged into Spitfire Audio community forum and reviewed these posts.

    6. Took stock of all downloaded Spitfire Audio samples.

    7. Found Spitfire Audio samples on two drives.

    8. Moved all Spitfire Audio samples to most permanent of the two drives.

    9. Repaired all Labs samples (clicked one of the libraries, clicked the gear, clicked 'repair all').

    10. Located, then repaired the Discover Plugin.

    11. Located, then repaired the Discover Samples.

    12. Closed, re-opened DAW.

    • Encountered Error 4 in the DAW

    14. In Spitfire application, noticed Labs libraries did not appear to be installed.

    15. Selected and installed Labs libraries individually.

    16. Confirmed Labs Samples available and working.

    For today, for my environment, for this product, this was the minimum reasonable path to resolution. It does not reflect poorly upon Spitfire Audio, nor do I expect to encounter another problem with the next software update.

    Next time I upgrade my storage or my system, the Spitfire Audio samples will be together.

    One huge word of thanks to everybody who posted here in this thread; it has been the difference between having, and having not, so many fun LABS sample libraries to play with!

  • I have some issues with very low volumes with labs and originals . I usually crank the volume with a gain plug or other and it’s not that bad but could be better. I hope lbs has an update for low volume and I wonder if any other users are experiencing this ?

    LABS seems to need re-installation often. I have messaged spitfire about they told me they are aware of this and they are working on the issue.

  • I don't get why they aren't able to fix this. Once everything starts misbehaving there is no correlation between what the Spitfire Audio app says is installed, what has actually been installed, or what shows up in the LABS vst. How hard is it to remember and read where some files are stored?

    Also, why can't it just repair without having to redownload all the samples when I already have the samples and there is nothing wrong with them?

    Last night I ran a Repair All and in the morning everything just seems more messed up then before.

  • It's annoying... I do wish they would put more effort into this. It really is (in my opinion) the only thing wrong with LABS.

  • Labs products are great quality -and free. Just saying :).

    Since the software update I've had stability - so am free to spread dischord throughout the universe.