Studio One 5.5.2, Abbey Road One Thematic Trumpets. Problem.

I just bought Thematic Trumpets. It's a trumpet sound - the trumpet sound for one song - that I've been looking for.

I can set a track up for each of the articulations and that works.

What I can't do is change articulations within a track using the key switches. I typed them into the correct pitch positions on the midi track. Nothing happened.

This could be because Studio One 5.5 has its own in-built articulations. I have a recollection of seeing a Spitfire Audio video - where one of the left hand widgets in studio One was used to programme in these key switches. Can I find it? No.

Could someone point me to the video or a way of resolving this please?



    The Instrument's interface shows each articulation's key switch. These are in the range C-1 to F#-1. The articulations work when selected through the interface but not when the keys C-1 to F#-1 are pressed. I found the YouTube video (see above). This stated that all Abbey Road articulations are in the C-2 to F#-2 range. I inputted them to the Studio One articulation widget in the C-1 to F#-1 range – (as per the instrument’s display panel) - nothing happened. I then shifted them down to C-2 to F#-2 - they worked.

    What is more - inputting the key switches directly in a MIDI track via manual edit - also works - in the C-2 to F#-2 range.

    So problem solved. But this is either a Studio One anomaly, or the displayed key switches on the user interface are an octave too high.

    Could someone from spitfire Audi please confirm this?

    Meanwhile… It’s such a fabulous trumpet sound – rich and sweet, powerful and with great flexibility. I have other trumpets – but nothing with the timbre of this VST. It’s cutting through and over my ‘big brass band’ verse ending superbly. Well pleased with it.

  • spitfire Audi?

    Sorry. Let me correct that auto-correct. Spitfire Audio.