Trouble learning CC automation with LABS and Originals [Solved]

jkatalenic
edited May 18 in Originals

Hello,

I am using Logic Pro X and have a template setup with instances of BBC Core, and a variety of LABS and Originals plugins. I am using a Roland A-49 Keyboard that has two assignable knobs I can manipulate automation with. I have assigned CC# automation for expression and dynamics for all instances of BBC Core. However, when I go to any of the LABS or Originals plugins, right click and try to learn CC# automation for expression and dynamics in those plugins, nothing happens like it doesn't recognize it.

Is this a problem with LABS and Originals that anyone else has had? Or can I not use the same knobs for different plugins, making it more a Logic Pro problem? (If so, that would be very inconvenient.)

Also, I know what numbers my two knobs are (CC#71 and #74) is there a way to manually assign these numbers to parameters?

Please HELP!!!!

Comments

  • Hi

    I'm no expert but if you can assign the 2 knobs to CC1 and CC11 in Core you should be able to do the same in Labs and Originals. Not sure why you are having problems.

    However, I would advise you to use faders for these controls. An inexpensive option would be the Korg nanoKontrol 2. It has 8 faders which (in CC mode) you can assign to any midi CC message. I have 4 of the faders set to CC1 modulation, CC 11 expression and CC21 vibrato. I also use another fader for CC7 "master" volume. There are also 8 knobs available (all assignable) and transport controls. Just a thought!

  • True, that is a very good point! And with that thought it's even more confusing as to why I'm having these issues ...I tried opening LABS/Originals in a blank session and had the same issue of not being able to assign them, very odd.

    I searched through some of the forums here and was seeing some people talk about these USB controllers with faders, and they definitely seem like a decent option! I would love for it to be able to work with what I already have, but as you said I'm sure it will be much easier/natural to control with faders as opposed to knobs.

    Thanks for your reply!!

  • Justin
    edited April 21

    Are you using the "Learn" mode correctly? When you click on "Learn MIDI CC# automation", nothing happens on screen. It is waiting for you to start moving the knob, wheel, or fader on your controller you want to assign.

    This works fine with my copy of the LABS plugin, so if it still doesn't work, try the "Repair" option in the Spitfire app for any of the LABS instruments, which will re-install the plugin.

    Contact support if this still does not work.

    In the meantime, you can change the CC# assignments for the two knobs on your controller itself.

    See page 38 of the manual. Page 8 describes how you enter in the CC# value using the keybed during this.

    https://static.roland.com/assets/media/pdf/A-49_eng08_W.pdf

    Expression is CC# 11, and dynamics is CC# 1. But since the mod wheel also sends CC# 1, I'd set the second knob to another parameter. Vibrato (CC# 21) would be my suggestion.

  • Angus
    Angus admin
    250 Likes 100 Comments 5 Answers Spitfire Employee

    If you are not using the default values @Justin and @Steve Shaw have mentioned above, you can of course reassign MIDI CC by following these steps:

    1. Control + Click on the slider you wish to assign
    2. Remove any MIDI CC assigned to that slider
    3. Control + Click again
    4. Select "Learn MIDI CC"
    5. Move the slider/ fader / knob you wish to use on your MIDI Keyboard. This should now be assigned.
    6. Save the patch in order to recall the change in another DAW session.

    However, I would recommend not reassigning the values, and instead, using a MIDI Controller that can be programmed to the default values listed in the article below:


  • To anyone interested or for some reason having the same problem, I found a workaround. I spoke with support and was trying several different options with nothing working. I could assign CC# automation for BBC but for some reason LABS and Originals wouldn't connect.

    In Logic I found the manual way to assign CC is clicking whatever parameter you want to assign, go to Logic - Control Surfaces - Learn Assignment for "_." There should be a shortcut as well. Hope this can help!

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!