BBCSO-Core Keyswitches Not Working

I'm not sure why, but keyswitches are not working. I'm using the default settings...Trigger is set to Keyswitch, Keyswitch selections are default, and Activate is Normal. I've tried a library Repair but no change. Instruments and articulations (when selected manually with a mouse) are all working fine. If it matters, I use Reaper.

Any ideas?? Thanks.

--Jeff

Comments

  • This may sound silly, but check to make sure you are in the right octave for the keyswitches. I had the same thing happen to me at first, but then I realized I was an octave too high.


    Hope that helps!

  • Yeah...I thought about this after posting my original. I tried all keyswitch octaves on the interface and the full range on my keyboard. Nothing. ;-(

    --Jeff

  • So difficult to judge what's your situation, but are you sure you checked each articulation's settings? I did find that surprising, probably because I usually first remove ALL articulations and then just add what I want. After that I have to set keyswitch and choose keys for each articulation separately!

  • BBCSO Discover here, so I can't speak for Core; thinking they should be same/similar? Appears to be working in Discover, although I'm still getting used to the concept.

    I think the defaults in Discover start at C-2, and while that "works" if I transpose the controller output and/or manually map the notes using the Score editor of Logic Pro, I have a tendency to remap them to the octave immediately below the sampled range of each instrument (where possible) and keyswitch while playing/recording.

    macOS 12.6, Logic Pro 10.7.4, BBCSO Core

  • I came here cause I had the same issue... In fact, the keyswitch of BBCSO Core is one octave higher than the one of my DAW (Cubase)...