Spitfire App shows no installed LABS products [Solved]



  • Must be quite frustrating as the title suggests it's been [Solved] when it seems it hasn't for some and if you come here expecting to find an answer but don't, then it doesn't look good!

  • I concur that the problem still exists. All the non-LABS products are showing up correctly. All LABS products (except Rare Groove Piano) that I have installed (and work fine in Logic) are showing as 'Not Installed' Products.

    I did have a long chat session with Spitfire Help last year and in the end had to download all the LABS products again (fortunately on 1 gig fibre so that didn't take too long ;) - and it solved the problem for a while (they were showing up). Since then I think I've downloaded any new LABS products, most recently the Christmas one, and on checking it has reverted to not showing LABS products (except that one).

    Is anyone else still having this issue?

  • HI @wadleysf

    I have created a support ticket for you so we can investigate.

  • Have you looked at your 'Properties' and 'Config' Files (Under main Settings - Troubleshooting) to see where the App thinks it is installing the LABS, here's mine and as you can see it thinks it is in 2 locations when they aren't, the Folder under /Users/sophie/Spitfire etc...doesn't even exist as that was the Default install location but now I moved all my LABS to an External as you can see in the other 'Location' (Volumes/320 7200/ etc.....)


  • Just to add, there is also another option in the SA App for where you install LABS, if you double click a LAB icon it shows this. under the little cog, bottom right you can see there is a 'Locate' option, I made sure that was also pointing to the external HDD, no idea if that Setting and the one in the Main Settings are related and/or causing conflicts!


  • Hi Folks @Angus @LMC

    Yes, I have just checked the properties file and for LABS only one location is mentioned:

    I see Angus has a ticket running - thanks!

    Since yesterday I did do the "repair" all my installed LABS (most, except four), and that put them back in the Installed status, for now. And as of this morning that's still true. I'll keep an eye on that next time I download a new LABS instrument and see if it changes.

  • LMC
    10 Comments First Anniversary 5 Likes First Answer
    edited January 2022

    The same happened to me the first time I installed some LABS and after making sure the App knew the correct Folder Locations before reinstalling, (Yes I had to!) it seems OK after a few week now, let's hope the 'Repair' option solved your issues as I've read doing the Repair option seems to work for some. 👍️

  • Have the same problem in Windows 10. Installed several LABS instruments (but not all) in one go in 8 of January. They are available and I use them in Cubase Pro 11. On the same day I logged back into Spitfire Audio app and it showed correctly which instruments were installed. However, today 12 January I logged into the Spitfire app and shows no instruments installed at all!

    I installed in the default locations suggested (Steinberg, VST). The LABS instruments are still available in Cubase Pro 11, no problem at all. Only that the Spitfire Audio app somehow cannot see that the instruments are installed. So, it is very difficult to keep track of which instruments are installed or not, and I might be missing in future updates because the app does not work properly.

    I can see that this problemn has been dragging for several months with no solution. It does not inspire confidence in using Spirfire products in general if the company is not able to sort out such a basic feature!

  • That's strange, i have the same issue. I'm surprised though that people have had this issue since a year almost. Is it not possible for the Spitfire Audio software to check for or at least manually locate the installed plugins?

    Seems like a very basic bug, it does go away when I click on "repair". It does not work even if i select "Locate" which is the bigger issue honestly.

    I'm on a metered connection so it's far too troublesome to keep repairing the libraries, hope this is fixed.

  • Hi guys, I have a small Dell workstation, a Precison 15 and I work with the NI Mk1! and with Ableton and really this is still happening. The truth is that the current structure of Windows file storage and its permissions forces installers to spread files all over the place. But the best thing is to put the installer and App to deploy everything in one place, I say. Native Instruments also spreads files all over the place but we can force it and then it respects the configuration and it works. But something is wrong with the Spitfire App - it doesn't seem easy to fix but it would be cool if it worked - I needed to retest the Brass trumpets - so it keeps happening - or is it fixed now? However the BBC Orchestra plugin, the free version works great! Greetings to everyone.

  • Update from my end.

    Mac OS Catalina 10.15.7, SA App 3.3.23 (just updated).

    Problem seems to still exist after downloading a new instrument. The existing instruments show up as installed just fine, but the new one does not.

    First of all, thanks to @LMC for the tip on checking the spitfire.properties file. Nothing was incorrect with mine.

    However, I decided to do a test. I moved the main Spitfire folder from users/myname to users/Documents/myname, updated that as my default download location in Settings, and also updated the spitfire.properties lines to reflect the desired install location of the instruments or where the app should look for them (I'm unaware). In any case, I thought it should be done to avoid discrepancy. Restarted the app, and as I suspected, I needed to locate everything, so I did that, and all was well. Restarted the app again just because, and everything remained just fine, showing up as installed

    Then, I downloaded a new LABS instrument. It downloaded just fine to the new location that I chose in Settings (users/Documents/myname) and according to spitfire.properties, and everything appears as it should in each of the three folders (Patches, Presets, Samples).

    However, here's the interesting part: the new instrument still doesn't show up as installed, even after restarting the app. I first used the locate option, but it didn't change anything. As before, I had to run "repair" to get it to show up as installed. So it seems like the problem could be deeper than a spitfire.properties discrepancy.

    I really doubt this has anything to do with moving the folder, updating the default download location, and updating the spitfire.properties file, because everything I already had installed worked just fine after running the "locate" option. Unfortunately, I didn't check whether or not the instrument was showing up in the LABS vst before running repair, but I'm sure it was fine. So it seems like something is amiss here with how the app is determining whether or not something is installed.

    Also, as a side note, each LABS instrument sometimes has multiple version folders inside, and I discovered that the Lap Steel instrument didn't have it's own folder in two of the three folders (Patches, Presets, Samples) and I had to make them. Not a gripe as LABS are free and it didn't seem to affect functionality, but it is an important file management oversight nonetheless that plays into whatever strange issue we're dealing with here in regard to the installed/not installed problem.

    Has anyone taken a look at the lm.log file after installing a new instrument, just to see what's going on? Same for when running a repair. That could tell us something. I unfortunately did not look before restarting the app after I installed the new instrument, and I don't have unlimited data to do that as an experiment. @Angus, perhaps the SA team could take it upon themselves to run such a test if they haven't already.

  • Nice update and thanks for the mention, I initially thought it might be a Permissions issue but after reading what you put not sure it just might be that, if at all?

    I noticed too that there are multiple Versions of each instrument, not sure what that is about, seems a bit 'Bloaty' if not all needed?

    I've not had time to look further into this but just had a quick look after reading your reply with 'opensnoop' in the Terminal and I noticed it refers to:

      501  4547 Spitfire Audio 18 /Users/sophie/Library/Saved Application State/com.spitfireaudio.spitfireaudio.savedState/windows.plist 

     501  4547 Spitfire Audio 18 /Users/sophie/Library/Saved Application State/com.spitfireaudio.spitfireaudio.savedState/data.data

    So maybe there's an issue with the 'Saved State' Permissions/Code/etc....? As it can't seem to remember what is where?


  • I'm running version 3.3.23 of the App on Windows 10 21H2 and can confirm that I still have to download and install each new LABS library twice for the app to register that it exists.

    I've noticed that in the Spitfire.properties file, both LABS and Labs are listed:

    Might this be what is causing the behaviour? If it is, which entry should I delete?



  • Also wanted to confirm that installing the Instrument, exiting out of the Spitfire Audio app, reopening the app and then installing the instrument again does allow it to stay in the installed tab. I'm also using version 3.3.23 for the App and my Windows is 10 version: 21H1

  • Just to add to this thread, I'm still having the problem that every time I install a new LABS instrument I have to install it a second time for the installer app to stop listing it as Not Installed.

    I've looked at my Spitfire.Properties file and noticed there seems to be two entries for LABS, one in all upper case, the other as "Labs" not all in upper case.

    The install folder on my drive is the upper case version, so am wondering if I delete the lines from the Properties file which relate to the lower case version, will that solve the problem? Of course, I won't know until the next Labs instrument is released. I've just downloaded the Vintage Drums (twice) so too late for that one.

  • same issue here, on mac etc. Have now downloaded the same Labs vst several times & it doesn't show up. Have also tried deleting Spitfire & re-installing, re-downloading the vst's etc. I'm on a limited data allowance contract so have eaten through lots of data & still no solution to the issue. I have to assume that despite the downloading process appearing to have actually happened (& the data used) no plug-ins are actually there as when trying to load in Reaper I get a message 'could not be loaded. Effect configuration is preserved'

  • Hello,

    I have encountered this issue previously, about four months ago. I have since installed some labs on a friend's computer and have encountered the same issue. So far this issue has been a 100% hit rate. This is concerning. If spitfire is going to require this app to run their instruments, I would hope that this app is well constructed. Both of my installation attempts were through a windows 10 operating system.

    I am sure that spitifre gets enough money to pay for an intern to put on this problem, or maybe that's the issue. Anyways, 'me need is want fixed. Do.'

  • Jumping in to say I'm having this issue too (Windows 10). This is only affecting instruments under LABS. I can use them just fine in Ableton but the Spitfire App shows them as uninstalled. I only downloaded a bunch of LABS instruments a few days ago so it still seems like a recent occurrence.

  • Everything is working fine now thank.you for the support and help in sorting out the software issue

  • I'm having same issue with Spitfire Audio 3.4. Internet coverage in my studio is awful, plus I have to use a WiFi dongle to connect to the Internet. So, I installed the app on my laptop and then downloaded the files there. They didn't show up as installed (Soft Piano, Choir & Modular Piano). So, I located the downloads and then moved them to my studio PC hoping I would just have to repair the path using the cog icon. However, instead of repairing the path it is downloading 93 mb files for each and at 0.2mbps this is going to take a long time. All inspiration for working on my project now gone.

  • I think the LABS player idea should be shelved until it is a properly working piece of software, and all the LABS libraries should be repurposed for Kontakt and/or Decent Sampler.

    Pianobook is a far better platform for the poor people who have spent so much time creating these fabulous libraries.

    It must be so disappointing that their creations are on an unreliable and professionally unusable platform.


  • I’m sorry for your experience with Labs but I am happy with the way labs works .

    As for having it in kontakt I must disagree for many of my students are happy with Labs the way it works .

    I personally feel it would be a grave mistake.

  • I don't think this is solved. It's still happening for me, Spitfire Audio version 3.4.0 on Windows 11.

  • Same here. Don't know why it has to download 92 MB just to recognize existing files.

  • Still happening. Just had to download all 1.72 Gb of LABS Cassette Synth twice.

    Out of interest, I tried clicking on "Repair" after the first install, and got a message of "You do not have any resets left for this package" so that didn't work.

  • I believe Spitfire doesn't give a shit about this issue or LABS in general because it's fucking 2023 and this hasn't been solved. I understand the plugin is free but it doesn't have to be an unsupported piece of garbage (obviously i'm not talking about the sounds/samples per se and whoever made them, they're great but the platform is trash).

  • New user. Got the same weirdness as most of you. Love the products but the app seems to have a life of it´s own.

  • yae...me, i do have this issue....i realy dont understand how spitfire is manage his files

    and i have jus LTE internet....all download again is not the option for me

    i just have em....so why it wont work....what is so hard for spitfire to locate their own libary?

    i mean, there are quite nice sounds....but all useles, if you cant use em....totaly stupid

    can me someone explain the difference between downloading the LAB or installing the LAB

    for what are these both options good for?

  • shiraishiku
    edited February 9

    Damn, this is really concerning. Such a powerful app, such beautiful instruments, yet 0 effort on their side to fix this and many other issues.

    It being Free shouldn't mean anything either. Lots of other free VST platforms and plugins have constant updates trying to fix their issues, but it's kind of unacceptable that we haven't heard ANYTHING since the beginning of last year. It's worse if you pay for this.