Spitfire App shows no installed LABS products [Solved]



  • @System64 I'll create a ticket for you and follow up soon.

  • Hey, I just installed the Spitfire Audio App and tried to download some of the APPS plugins, however, when the plugins are finally downloaded I can't access them. How can I access the plugins after downloaded?

  • HI @Dias3345356

    You will need to use a Digital Audio Workstation in order to open the plugins. If you're not sure how to open them in your DAW, let me know which DAW you are using and I'll be able to advise.

  • Angus, can I check or do something to avoid installing of each new library twice?

  • @wn6 we have a new App that is still under testing that fixes this. We'll hope to release this before Black Friday- thanks for your patience in the meantime.

  • Well, this is so frustrating! According to Windows Explorer all my Patches, Presets and Samples are present, yet the Spitfire App shows them as 'Not Installed' - this was after downloading the 'Siren Songs' module. I've done all the checks for permissions as detailed, downloaded the latest Spitfire App, re-installed one module and then run a Repair All LABS, but they are still showing as Not Installed. There are more problems with LABS than any other plugin I've ever used.......

  • RobinB
    edited October 2021

    As a follow up - I've discovered that if I click on one of the apparently Not Installed products and then run a repair on that, the product downloads a much smaller file than that described on the Not Installed icon (eg 114MB as opposed to the product of over 600MB for Arctic Swells) and the product then appears in the Installed section and is available in my DAW. It means that I have to go through each Not Installed product and run a repair. Unfortunately there is no Repair All option for not installed products, as in the Installed products, but as a work-around it is much quicker and less damaging to my limited internet connection than re-installing each product fully. Still very frustrating to have to go through this process when the products are actually on my computer and were working fine before I ran the latest product install.....

  • I'm experiencing the same issue, can't find installed products in the app but they appear in file explorer. Windows 10.

  • Hello, I have got same problem - I installed a LAB, it appeared as Installed, but later it disappeared. I tried several other LABs but they do not list in installed. I can see them in DAW but I cannot hear them there, I'm getting Error #4. In fact I can hear just one of the LABs that I installed. Only one.

  • @Mauritz and @jannovak do the products listed as "Not Installed" appear in the LABS Plugin?

  • same problem here. Choir and Electric piano are ok, all other LABS are always shown as "not installed" even If I installed them 200 times.

  • Hi @sanbaldo

    I'll create a ticket for you so we can investigate.

  • zzz
    First Comment
    edited November 2021

    I can confirm - at least for LABS - that running a repair for each known installed library seems to alleviate the issue of known installed libraries not showing up under the "Installed" directory.

    For anyone who is unaware of the process (version 3.3.18):

    (1) Open the Spitfire App, go to the "Not Installed" directory and locate a known installed library (for either LABS or My Products) (you can more clearly double check your installed libraries by opening the "Patches" folder inside of the folder set as your "default content path" for a neater list compared to opening the LABS plugin in your DAW).

    (2) Click the library's picture (NOT "INSTALL") to go to that library's page, find and click the little cog wheel to the right of the "Install" button, then click "Repair" for an approximately 120mb download/install.

    (3) Close and reopen the Spitfire app and check the "Installed" directory to confirm it works.

    (4) Go ahead and start a repair for all known installed libraries, wait for everything to finish, then close/reopen the app to confirm everything stays in "Installed"

    Considering the relatively small file size and bandwidth requirement (as opposed to reinstalling full libraries), this seems like a fine workaround until a new version of the Spitfire App that resolved this issue is released. This also avoids needing to give the app Full Disk Access, which I think is an entirely unnecessary - and unreasonable - requirement.

    Thanks to everyone here who has contributed to this thread.

  • Having this same issue. Have tried the fixes suggested and nothing has worked. Incredibly frustrating.

  • Hi @myceliant

    I have created a support ticket for you so one of our agents can assist.

  • I am having the same problem. Only some of the libraries show up when opening them from the VSTi in DAW, installed shows zero libraries, reparing one helped for that one - but it is hard to repair all of them every day - I did that once and after a month everything went back to not installed again. :/ A repair all button would be nice at least...

  • Geefunker
    edited November 2021

    I am experiencing the same thing where nothing I’ve installed shows up within the Labs - Installed tab. Through re-downloading instruments a bunch of times I’ve managed to get them all to appear in my DAW. Except on some instruments I’m getting the “Error #4” which renders them useless in my DAW and I’m unable to repair them within the Spitfire App as they do not appear in the app whatsoever. When I go to re-download these “Error #4” instruments, nothing happens as I still get the error, even after a full restart/refresh of the app , refreshing plugins within my DAW, etc. One of these had worked previously before breaking, so I have tracks tied to these sounds within my DAW that are now just dead MIDI tracks as the sounds obviously don’t playback anymore once broken. Good times Spitfire! If someone could open me a ticket it would be much appreciated.

  • @Geefunker I've created a ticket for you- alternatively, you can contact our team in live chat hours here: www.spitfireaudio.com/support

  • mlepage
    edited December 2021

    This must be an ongoing problem. I just uninstalled Spitfire Audio, reinstalled 3.3.18, changed the content dir to C:\Data, and installed 21 of the LABS instruments. They are all installed under C:\Data, however even restarting LABS several times, not a single one shows as "installed".

    I also followed the procedure outlined by user zzz half a dozen posts above, and it had no effect. Before and after installing Amplified Cello Quartet into an empty "Spitfire Audio - LABS" directory, it was 350 MB, 77 files, 14 folders.

    There also seems to be a discrepancy with the "Spitfire.properties" file located in "%APPDATA%\Roaming\Spitfire Audio\Settings" because even after changing my content directory in settings, it still pointed to the default location under C:\Users. (Or is that file from an earlier install? Is it even used anymore? Because the installed did seem to go into C:\Data, not where Spitfire.properties was pointing...)

    All in all, it seems there are some bugs to work out.

  • Another issue which may be a clue.

    I just removed the entire install of Spitfire Audio, and all its little settings and content directories, to try to start clean. I installed Amplified Cello Quartet (into content C:\Data) and it was downloading. After completion, it was no longer in the downloading tab, but the main page still says "install" and of course it still shows as "not installed" and not as "installed". All this we know from the above contents.

    What I also notice, is if I then attempt to close the app, it says it's still downloading. (Even though nothing is showing in the downloading tab.) It does this even if I cancel and try to close the app again, several times.

    So maybe there is some app confusion about some final stage of downloading or installing, some step which is not being properly completed, or marked as completed.

  • One more discrepancy:

    When I do a completely clean install (as if on a new computer), my Spitfire.properties file lists locations for Patches, Presets, and Samples, and they are in C:\Data which I set in the app. So far so good.

    But when I actually install a first LABS instrument, it creates directories for Patches and Presets, but not for Samples. I just have a bunch of separate NUMBER.lm files (e.g. 942079.lm, 21998742-57621662.lm, etc.) files alongside Patches and Presets directories.

    So, why isn't a Samples directory created? Was a final step meant to be to move the .lm files (which I presume are sample data) into a Samples directory, and that failed for whatever reason?

    Or, if a Samples directory is no longer required, why is it still listed in the newly created Spitfire.properties file?

    Either way, something seems to be not working correctly.

  • mlepage
    edited December 2021

    OK, I have sorta solved it and sorta figured out what is happening, at least with my issue, which is not unique to me.

    First, it seems there is an actual bug with the installer: it's not creating the Samples folder.


    In that thread, they are claiming it was fixed about a month ago, but that must be in a beta release, because the bug is still happening in latest public release 3.3.18 (which is what I've been using today). As noted above, the final extraction of sample data into Samples folder is not successful, even though in my case, I have about 250GB of space, and the installer can write other files to the install location. So this needs to be fixed, and maybe is already fixed in a newer release, but that release needs to actually be released.

    So, I had a hunch that although this is happening for some people (not just me), it can't be happening for EVERYONE, can it, because otherwise they'd have pushed the release with the fix. So, since I was setting my content path to another folder, I tried again with a clean install, and left the content path with its default location (under my C:\Users folder). And it installed correctly, made the Samples dir, shows as "installed" in Spitfire Audio app, and it works in Ableton Live 11.

    Great, it's working. But I want the content installed in a non-default location. So, the task now is to move the working content folder from its default location to my desired location, C:\Data.

    I shut everything down, opened Spitfire Audio, changed the content path in settings, closed the app. It didn't move the content folder or adjust Spitfire.properties, so I manually moved the content folder, and edited Spitfire.properties in Notepad, so it pointed at the new location. (Spitfire.properties is in %APPDATA%\Roaming\Spitfire Audio\Settings)

    At this point, the LABS instrument still worked in Ableton Live, the Spitfire Audio app still showed it as installed.

    However, trying to install a new LABS instrument DOES NOT WORK and exhibits THE SAME BUG. It does not show as "installed" and inspection of the content folder shows that although it unpacked the Patches and Presets correctly, and there is a functional Samples folder, again it fails to finish installing the *.lm sample files into the Samples folder, and leaves them scattered. Even if I manually create the appropriate LABS instrument subfolder inside the Samples folder and reinstall the LABS instrument, it doesn't use it.

    So as far as I can tell, the latest public release of Spitfire Audio is currently broken if using LABS with a custom content path.

  • I'm having the same issue, but glad to see some really good insight here.

    Has anyone been able to figure out a way to manually take the scattered .lm sample files and organize them in a way that allows them to run the lab in their DAW?

  • i am on Windows 10... had the same issue.

    worth noting, i also have my content on an external drive...

    <<< i believe the main issue is Cloudfront >>>

    i went into the settings and turned OFF Cloudfront CDN

    i also noticed a specific lab named "Frozen Strings" was not showing it's download size. i re-downloaded it without doing any other labs at the same time and then restarted the app.

    once both of those things were done.... from that point i could install any lab, reboot the app and they all worked.

  • perqa
    edited December 2021

    Same issue here. Out of all those patches, only two are displayed as installed. Same permissions on all folders.

    The solution outlined above by zzz from November 8 works, it's just very tedious with so many patches. They're all free and all great, so I don't complain. But I have also purchased products from Spitfire, and I wouldn't want them to disappear too.

  • GregB
    edited December 2021

    Interesting conversation. I too have Big Sur (11.6.1) running on an M1 Mac mini and its now 15 December 2021. I've downloaded many of the LABs library samples yet most don't show correctly in the Spitfire Audio app.

    While this is a minor irritation and should just work, especially given the downloads and folders where these are stored, are managed by the Spitfire app, I haven't worried about it.

    My purchased sample packs do get properly represented and managed which is good.

  • it’s 2022 the problem still there,unbelievable

    MacBook air m1

  • This did happen to me a week after I installed the App but reinstalled all the LABS I needed and been fine for a few weeks now, what I did do before reinstalling was made sure all my folders where set up in the Settings and made sure the Folders on the External HDD where named properly, I think what could be confusing the install is that there are 2 options for the folder locations in the App.

    One in the main settings, 'Default Content Path' which I made sure was set up on the External HDD and there is a 2nd option in the actual LAB Options, if you click the LAB you have installed there is a small cog, bottom right with the option to 'Locate', which I have pointed to the same Folder on the External.

    May not be the solution but seems counterproductive to have 2 sets of Settings for the same thing, so may be confusing the install if not set right?

    Just a thought!

    (Even though on the 2nd Screenshot it doesn't show the actual folder, it does point to the same as the 'Default Content Path')

  • LMC
    10 Comments First Anniversary 5 Likes First Answer
    edited January 2022

    Just to add, as just double checked, the Config File and Properties File both show the Default Folder Location, so maybe check both of those to see what they say!

    In the 'Properties' file you will notice the first line for LABS in the 'patches/presets/samples' location '/Users/sophie/ etc...../' does not actually exist as the Spitfire Folder in that location is empty.

  • Try again: (See below)

    Also just double checked my SA Config File and Properties file and as you can see both point to my 'Default Folder Location', so maybe check both of those to see what they say, you will notice that the first line in the 'Labs' location doesn't actually exist, there is a 'Spitfire Folder in /Users/sophie/ etc....' but it is empty!

    (Just tried to Edit the original post and it just disappeared (Not the first time so maybe a look at the Forum SW as it will put people off posting if it doesn't work!)