Need some much needed help with Studio One 5 and BBCSO Core [Solved]

Can anyone give me step by step instructions how they got Studio One 5 Pro to see BBCSO Core in the DAW? I love this DAW but I am I guess still green when it comes to just loading plugins its ALWAYS a hassle no matter what I do.

I even re downloaded it and it still won't see it. I can see the download in the files but when I go to instruments nothing and its not on the plugin mgr etc.

Im on a Mac mini os 11.5.1 Big Sur 32 GB 6 core with an External Samsung T5 2 TB SSD Drive

Sorry Im sure its operator error but I'm getting frustrated it just shouldn't be this difficult.

Thank you for ANY help! lol


Best Answers

  • Hannu
    edited January 2022 Answer ✓

    Start Spitfire Audio application.

    Click on BBCSO Core. Next, click the cog wheel symbol next to "Installed" "Repair" words - and press "Locate" IF the plug-in content doesn't already say "Installed" and everything is OK.

    Open Terminal from your Apps -> Utilities folder, and paste this command there and press Enter:

    killall -9 AudioComponentRegistrar

    This forces Mac to search for any and all changes made to Audio Unit (AU) plug-in installations.

    Start Studio One 5. I can see BBCSO under "Instruments" twice, both as VST3 and AU. I'd go to Plug-in Manager to the right hand side of the window and click "Turn Plug-in formats on or off" and disable VTS 2.4 and VST3 and use AU only when on a Mac, This way you won't see the duplicate entries either on the plug-in list in the future.

    On a rare occasion you need to change the read/write folder permissions for the Plug-ins folder inside your Mac's system, but reach out to me if you need help with that.

    Hope this helps!


  • going to try this now!

    Thank you! Ill buy you a coffee or something for your help!

    Ill let you know how this goes!

    Thank you sir!

  • I just noticed that where it should say installed there is a red ! mark...what does that mean?

  • Hannu
    edited January 2022 Answer ✓

    That means one of the errors explained on the Spitfire error messages. Click on that and you'll see the error number, but anyway: I'd recommend you click the cog wheel on the line where it says BBCSO Plugin and 1. click first "Repair" 2. (and then if needed "Reset" from the cog wheel menu) in order to re-install the latest version of the plugin, 1.5.0 at the time of writing. Also, BBCSO Core line should updated to version 1.5.0 if it has the same red exclamation mark.

  • I messaged you on Facebook messenger :)


  • Hannu
    edited January 2022

    The answer was this: the user had accidentally duplicated his Studio One 5 app in the Applications folder and started the duplicate, hence no BBCSO plugin was working or visible in the app. When we reinstalled BBCSO Core and removed the duplicate app and emptied the trash, everything worked fine.