Albion One Time Machine Patches do NOTHING

Is any one else getting no results with the "Stretch" slider in Albion one TM patches? I've tried all of them and re-installed (Reset) my library. NEO works as expected.

Comments

  • It even seems that the "Release" slider is non functional in those patches, but it may be a limitation of the articulations.

  • Can anyone confirm this?

  • So this is a known issue according to Spitfire. Curious how Paul's walk through video tells you about the stretch functionality in Albion One but never actually demonstrates it...

    Lot's of fixes in the update in August but no one has yet to find this? Very Strange...

  • Hi @Five18Studios

    I have reported the issue with the latest update. Anyone else experiencing this can reach out to the Customer Experience team to be notified on when the next update is made that patches this issue: www.spitfireaudio.com/support

  • Is there a fix for this soon? It's very frustrating buying a library that's been out LITERALLY for years and is still broken. 2 months and no fix?

  • Silence...

  • KenJ
    edited March 7

    Just adding a data point. I tried the TM patches on my Albion One and the stretch slider also does nothing.

    Curious, when did this functionality break? Was it the July 2021 update? I haven't used Time Machine patches yet so didn't notice.

  • Five18Studios
    edited April 4

    4 months later and still no fix for a decade old library...


    I've lost hope that there will be one


    Christian and Paul must be sooooo proud...

  • Abandon all hope ye who bought this library... For alas, there are untold problems that may never be addressed.


    And yet this library (broken) is ON SALE! Wow!