Important Statement Regarding Recent Originals Updates

Stewart
Stewart mod
10 Comments First Anniversary First Answer Spitfire Employee
edited November 2021 in Originals

Earlier this week, we began sending updates to Originals customers to enable full M1 (Apple Silicon) compatibility.

Shortly after it was released, we were made aware of an issue with the UUID when using the VST3 version of the plugin, which essentially means that the new plugin could not recall previous DAW sessions. This is obviously an issue that needs to be urgently addressed, and as such, we have pulled the update for users who did not yet receive it. If you're using the other plugin types such as AU (Logic & Ableton) AAX (Pro Tools) or the VST2, you will not encounter this issue.

If you have updated your Originals, please do not save any sessions where you have used the VST3 version of the plugin - as this will mean you will be unable recall the session when we release an updated plugin with the original UUID.

If you have purchased any of the Originals since Monday 22nd November, you would have also received the Originals with the issue. This means that any DAW sessions you have made with the Originals since purchase will be affected when we revert the UUID back to the original. You should therefore contact support at www.spitfireaudio.com/support

We do not have a timeline regarding when the update will be ready to download, but we will update this post once the updates are made available for all Originals that correct this issue. 

If you have any questions, please feel free to drop a comment below or contact our support team directly for advice. In response to this, we have carried out a full investigation as to how this was possible, and will also be improving our testing processes to avoid this happening in the future.

We apologize for any inconvenience this has caused.

Comments

  • Hi, I've had a different problem since the update. All my Originals libraries now no longer show up in Logic. The .component files are in library/audio/plugins/components as they should be, and I've tried things like deleting the au cache and rescanning, and restarting the computer, but no luck. I've also downloaded the free demo of The Stack, and this isn't showing up either. My other Spitfire libraries are working just fine, but it seems any that have been recently installed or updated do not. Any idea why this might be?

  • @Yappobiscuits I've created a support ticket for you so that our team can investigate.

  • Stewart
    Stewart mod
    10 Comments First Anniversary First Answer Spitfire Employee
    edited November 2021

    This issue has now been fixed. If you were experiencing the issue following the most recent update, you will need to repair all of the affected Originals after deleting the plugin files in the following locations.

    Mac

    AU: MacHD/Library/Audio/Plug Ins/Components

    VST: MacHD/Library/Audio/Plug Ins/VST

    VST3: MacHD/Library/Audio/Plug Ins/VST3

    AAX: MacHD/Library/Application Support/Avid/Audio/Plug Ins

    Windows

    64-bit AAX: C:\Program Files\Common Files\Avid\Audio\Plug-Ins

    64-bit VST: C:\Program Files\VstPlugins

    64-bit VST3: C:\Program Files\Common Files\VST3

    The updated plugin files will then install and should allow for the plugins to load upon restarting your DAW. Please contact support via www.spitfireaudio.com/support if you encounter any issues after doing so!

  • For any Windows user who is not so technologically inclined and has been regularly backing up their system drive:

    You can restore the vst3 files simply by copying backups of these files made prior to the fateful update to the "C:\Program Files\Common Files\VST3" folder.

    Once restored, I rescanned with my DAW and am back in business.

    I'm a software engineer. I made this same error once.