PeerBlock app creates issues with LABS, Regained faith in SpirtfireAudio

I just recently noticed that my LABS instruments folder was around 22GB. I figured I would move my LABS folder to my external HD (Western Digital 4TB SSID), to free up space on both the ASUS Win10 laptop and the new MacBook M1.

I should have noticed the problem from the get, when I needed to close PeerBlock to "repair" my libraries after the move. It worked flawlessly with the Mac. I was unsure whether or not sharing the same library between the Mac and the Win laptop would create more issues, so because I had the free space, I duplicated the LABS folder so that the each OS could have it's own dedicated Library. (Redundant, but I didn't know if sharing the main folder would work, or cause me to have to repair and repair and repair and repair)

Everything showed up as working fine with the Spitfire App, but when I would open the actual plugin VST3 in FL Studio it was giving the infamous Error #1 message. Even though it was looking perfect in the App. Mind you, this is after hours of repairing each individual instrument, repeatedly, hoping to remedy Error#1.

The epiphany hit me, to close PeerBlock when opening my DAW (FL) and opening LABS. It worked. Oh hindsight.. so clear you are.

So, I just wanted to write and include this information into the aether to helpfully help anyone else who is using an ancient IP blocker like myself. =)

  • SselemaN