To upgrade to Windows 11 or not to upgrade to Windows 11?

My computer has started encouraging me to upgrade to Windows 11. Has anyone here taken the plunge? Has it affected your Spitfire (or other) plugins, audio drivers or DAW?

Comments

  • Russell
    edited November 4

    @HewWagner Software companies will always try to get you to upgrade to the latest and greatest OS or whatever. It's really up to the user to research all of the applications they use via the mfg. and be sure they're all qualified for the SW.

    With Windows 11 I'd be more concerned with whether or not the CPU is upgradable. If you're getting prompts it probably is. Microsoft has a cutoff point. For instance I run a very high end enterprise workstation and it can't be upgraded to Win 11. As they say "Caveat emptor".

  • I haven't seen anything about Windows 11 that will improve my music-makin' yet, so I'm holding off!

  • I recently upgraded my spare music laptop (HP Zbook 17 G5) to Windows 11 pro just to see if my music apps would still work. I’ve not had any issues yet.

    I’m running:

    -Cubase Pro 11, Studio One Pro 5.4, Digital Performer 11, Orb Composer Pro 1.5,…

    all plugins seem to work fine too.

  • RothenburgODT
    edited November 12


    Are You able to install the latest LABS instrument (Electric Guitars)? I'm not because it seems like Windows doesn't allow to install the 32 Bit DLL (LABS (32 Bit).dll) anymore. My Log's saying:

    2021-11-13 00:11:59.928037 [8332] [E] Unzipping Warning: Can't restore time Entry: F:\VST32\LABS (32 Bit).dll - Source Zip: C:\Content\Spitfire\Spitfire Audio - LABS\21159919-72097887.lm

    So I'd like to understand if this is a general Spitfire/Windows 11 issue or not (I didn't find a way to leave the 32 Bit stuff out for installation)...

  • I always wait at least 6 months

  • @RothenburgODT

    No, I’m not running Labs on that computer so, I could comment on it.

    But I assume Labs is using the same player framework as BBCSO and Abbey Road One and those do work fine.

  • Thanks for Your reply! I'll give it another try but it also would be great if someone already working with Win 11 can report if it worked with the lates LABS installation or not.

  • I run LABS on my Windows 11 computer and i dont have any issues, neither on "old" LABS nor new installed ones.

  • I could fix it by using the standard vst-folders on my main drive. All my vst stuff is located on an external drive and for any reason the installation doesn't allow it anymore for spitfire/Win 11. Other applications still can handle it. However, now I install on C and move the vst-Files to the external drive after the install process. One additional step but it works...